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1 General 

1.1 About contents 

This document provides a detailed description of how a MicroController XC technological PLC is 

programmed and configured with the graphical tool FirstGraf. FirstGraf will function with  Windows 

XP, Windows 7 and Windows 8. 

 

1.2 Revisions 

Nr Date Comment  Ref 
1 2013-05-12 Manual MicroController XC with FirstGraph first version to be 

checked by selected OEM customers. 

 GB 

2 2013-06-04 Correction of Modbus slave  GB 

3 2014-04-19 New functions Modbus UDP and automatic search units  GB 

4 2016-03-07 New unit XC05 and firstgraph changes  JÖ 

5 2016-11-01 FirstGraph updates  JÖ 

6 2017-07-01 FirstGraph with Modelica  JÖ 

7 2017-10-11 Changes in IP-configuration  JÖ 

 
 
 

 
 

All the software described in this document is the properties of First Control and may not be used in any other way than is 

specified in the License conditions that is included in each delivery. This means that the software may not be copied, installed 

or given to any other party which is not explicitly specified in the License conditions. First Control takes no technical or 

economical responsibility whatsoever of how the software is used in the specific installation. Any violation of the license 

conditions is handled according to Swedish law at a Swedish court. 
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2 The MicroController XC control system 

2.1 System Overview. 

The MicroController XC is part of a DCS system FirstOpNet, but can also be used independently in a 

process installation. MicroController XC units are today installed in a larger number of different 

processes ranging from steel mills, energy production  to embedded solutions for specific machines. 

You can read more about the FirstOpNet concept and MicroController XC installations on First 

Control’s web site  www.firstcontrol.se 

 

 
 

 

 

 

 

 

 

 

 
The MicoController XC system is a powerful technological PLC which can do more than standard 

control systems. In the object library you can find First Control's awarded adaptive regulators and 

other advanced control functions which are much more efficient than you can find in conventional PLC 

systems.   

2.2 The MicroController XC system 

There are currently five different versions of the MicroController XC: 

 

MicroController XC01 Technological PLC for general automation 

MicroController XC02 Technological PLC for special applications 

MicroController XC03 Technological PLC for steel applications 

MicroController XC04 PC software for offline programming and simulation in Windows 

MicroController XC04F PC software for running control programs in Windows 

MicroController XC05 Technological PLC for general automation 

 

The different  MicroController XC units are very much alike and are programmed in the same way. 

They differ mainly in the local process I/O  that is found on each units to fit a special application area. 

 

 

 
 MicroController XC03 in a rolling mill installation              MicroController XC01 in energy production 
 

A FirstOpNet control system for a 

distributed energy production network. 
A FirstOpNet control system for a cold 

rolling mill. 
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There are some very powerful features which makes the MicroController XC unique and  much easier 

to program than other control systems: 

 

• Multitasking Control Schemes 

Most other PLC systems are sequence machines. The MicroController creates true multi-

tasking control schemes. The execution order is automatic and based on how  the different 

control objects are connected to each other.  Automatic sequencing is a very strong feature of 

the MicroController XC which prevents many hard found errors due to “undefined signals” or 

“irregular execution order”.  

• Large local function library 

A function library with about 150 function modules is available locally in the unit itself ready 
to be used in application programs without external loads. It contains all the function you 

need for an automation project, including First Controls awarded adaptive controllers 

• On-line editing of control programs 

The MicroController XC can be programmed safely on-line and an edited program is loaded 

within about 0.2 msec and always within one program cycle.  Moreover, when the change 

occurs, the system will make a “hot” load, i.e. all unchanged parts continue to run with the 

same internal data as before  

• Automatic graphical documentation 

The programs are automatically drawn by the programming tool FirstGraph directly from the 

application code stored in the MicroController XC itself.  The same is true for all settings and 

configurations made in the unit. This also means that FirstGraph can make an exact 

documentation of  a completely unknown application software in a few seconds by simply 

connecting it to the PLC unit. 
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3 Application projects 

3.1 Application data 

 
  

Application Project 

System Timers 

Process interface 

Communication 

IP adress & 

Identity 

Setups & configurations 

Application Program nr 3 

Application Program nr 2 

Application programs 

Application Program nr 1 

 
 
A complete Application project  in a MicroController XC consists of . 

 

1. Application programs  

2. Setups and configurations 

 

The individual parts are all displayed in the information tree shown below  which gives you  an 

immediate overview of the whole application. This can differ between the different XC systems 

depending on I/O. 

 
 

 

 

 

 

 

 

 

 

 
 

 

 

 

 

 

 

 

 

  

Contents of the main groups in the information 

tree: 

 

MC1 (XC04) The target system 

Programs Application programs  

I/O Reserved for future display of 

I/O values 

Database Display of internal database 
values 

System info Display of system data 

Settings All the internal settings that can 
be made in the system 

Backup The backup programs  
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3.2 The programming tool FirstGraph 

The FirstGraph tool replaces the older FirstDoc tool previously used with MicroController XC systems. 

 
FirstGraph is a PC software which can be used with Windows XP, Windows 7 and Windows 8.  It 

works in a direct communication dialogue with the the target system where each side always updates 

each other.   What you see in the tool is therefore an exact copy of the contents  of the target. This 

means that there can never be a problem of version errors since you always have the latest version of 

your target system automatically in your tool. 

 

With the FirstGraph tool you can do the following: 

• Programming application programs 

• Creating the local database 

• Making all configurations and settings 

• Display of all current database values 

• Display of all signal values in application programs directly on the drawing 

• Making a complete documentation also of unknown application software 

• Safety backups of a control project 

 

Important notice. To be used with target systems  XC01 and XC03 you should upgrade the base PLC 

software in the units in order to speed up the communication with the programming tool. 

 

You can use the Programming tool with the following MicroController XC versions: 

• MicroController XC01  

• MicroController XC03 

• MicroController XC04 

• MicroController XC04F 

• MicroController XC05 

 
You can also use part of the powerful tools in FirstGraph in programming XC02. 

 

3.3 Connecting to a PC 
 

 

  

The XC device must be connected directly to a computer via an Ethernet network by a 

crossed Ethernet cable. 

 

Default network configuration 

 
The following configuration is set on the XC-device by default: 

 

IP address: 192.168.2.4 

Subnet Mask: 255.255.255.0 

 

This information will be used in the next step. 
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Computer IP Configuration 

 
The computer (PC) must have the same network subnet mask as the XC-device. Taking into account 

the factory setting s of the device (shown above) a computer must have the following IP configuration: 

 

IP address: 192.168.2.X 

Subnet Mask: 255.255.255.0 

 

where X is any value between 1-254. 

Examples of valid IP addresses are: 192.168.2.1 and 192.168.2.102 

 

When connecting the device to a LAN, the IP address 192.168.2.1 is reserved and given to a router 

or switching device 

 

An example of a correct IP configuration in the Windows system is shown below (Control Panel > 

Network Connections > Local Area Connection > Internet Protocol TCP/IP > Properties). 
 

 

 

 

3.4 Start a new empty projekt 

You start FirstGraph by clicking on the program icon or the exe file. If you choose 

File → New Project  from the file menu you will get a new  ”empty project” that will look like this. 
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The information tree now contains two objects created by default settings: 

 

MC1(XC01) 

 

Information about target system 

In this part you will have all the application data from the running 

MicroController unit where the default setting  means 

• MC1 MicroController unit nr 1 

• XC01 MicroController version XC01 

Backup Information about backup data 
In this part you will have your backup data which can be loaded into the 

target system. 

 

Both parts are empty until you start programming. 

 

Connect to the system from a PC 
 

The FirstGraph tool always runs with a target system which can be a physical PLC like XC01 or XC05 or 

an offline system in your PC such as XC04.  The first thing you have to do is to identify the target 

system  with its IP adress.  FirstGraph will then find out which version is connected. 

The default IP address of a new system is always 192.168.2.4 (XC05). 

 

 

 
 
Search for Controllers 

  

The easiest way to connect to the target is to select File → Search for controllers in the file menu  and 

click on the button “Start search”.  FirstGraph will then find all units connected to the network that 

has the same net mask. 

 

 
 

In this example there are two units found: 
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• One internal XC04 unit  running in the same PC as the FirstGraph software. 

• One external XC01 unit connected via an ethernet cable.  

The corresponding IP addresses are displayed in the second column.  You can select the unit you want 

to connect to by  double-clicking  with the left mouse button on the IP adress : 

 

 

   
 

If you select “OK” FirstGraph will connect you to the target system.   

 

You can also click on an IP address with the  right mouse button  on the IP adress. You will then get the 

following selections: 

 

 
 

If you select “Connect”  it will be the same as above.   You can also select  “Change the IP address” and 

type in a new one for  the target unit; 

 

 
 

alternatively you can select  File → Configure IP-address  in the file menu and fill in the IP address: 
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The target system property decides which target system you want to connect to. Available systems are 
(XC01,XC02,XC03,XC04 and XC05) 

The IP address settings  in this case means that we are connecting ourselves to a XC04 unit running in 

the same PC.  Then click on Connect in the menu line and you will be connected to the target system 

which immediately will  communicate all its contents to the tool.  

 

You will then get a new information tree which in this case is empty since no programming has been 

made.  By expanding the tree the main groups for details we will have: 
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Information tree 

 

 

 

 

 

 

 

 
 

 

 

 

Below we will go through the whole information tree in detail 

and show how you fill it in and make displays of your 

application. 

 

 

 
 

 

 

3.5 Open an existing project 

If you choose File → Open  Project  from the file menu you will get a browser where you look up the 

project you want to open.   

 

 
 

FirstGraph accepts the following two file formats: 

 

Contents of the main groups in the information tree: 

 

MC1 (XC04) The target system 

Programs Application programs  

I/O Reserved for future display of I/O values 

Database Display of internal database values 

System info Display of system data 

Settings All the internal settings that can be 

made in the system 

Backup The backup programs  
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.mcd File generated by FirstGraph 

.fdo File generated by FirstDoc, i.e. the previous  programming tool 

 

When you open a FirstDoc file it is first converted to the new FirstGraph format: 

 

 
 

If you answer “Yes” the file will be converted which takes a few seconds.  

 

Important notice. This means that all applications made with the old programming tool FirstDoc can 

be reused in the new graphical version FirstGraph by a simple automatic conversion. As is explained 

below, you can also go the opposite way,  i.e. save the file in a FirstDoc format. 
 

When you open an old project all data will be in the Backup area initially and no data in the the Target 

area  MC 1(XC04): 

 

 
 

Before you can start your programming you must first identify your target system in exactly the same 

way as you did for a new project described above, i.e. 

 

• Select  File → Configure IP-adress and fill in the target IP adress 

• Click on Connect  to get in contact with the target unit 
 

As soon you are in contact with the target system the tool will immediately be updated  with all the 

contents  of the target system in the upper part of the information tree. The contents can be 

compared with the application programs that are present in the Backup 

 

Loading the backup to the target system 

After you have a connections you can load the the backup application into the target system by 

selecting  File → Download application to unit.   You will get a question if you want to clear the unit 

before loading. 
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If you do not clear the area, the backup application will be loaded on top of the existing programs and 

replace those having the same program number while leaving the remaining ones unchanged. If you 
answer “Yes” the unit will be cleared before loading the application. 

 

 
 

Since we have loaded the backup in this case the program contents will be the same as you saw in the 
Backup part above. 

 

Warning. 

Loading a backup or a single program will always result in a restart of the unit. Hence, the loading 

procedure should not be done in a running system. 

 

3.6 Safety backups 

Local backups inside target system XC01 and XC03 
The control application is locally protected in several different ways to prevent failure at power switch 

off/on: 

 

• Auto backup in local battery RAM  
The operative will always save the current application area whenever  you end a programming 

session in a local RAM memory which is protected by battery.   The control application is 

automatic generated from the application files stored in this area when you switch on power. 

 

• Auto backup in local Flash  

If you make a disconnection of the of the unit by selecting File →Disconnect command in the 

File Menu the application is automatic saved in an Auto Save area in the local Flash memory. 
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At power ON the application files are then read from this area at start up. 

 

• Manual backup in flash 

By selecting File →Backup unit  in flash the application project can be  stored in two local 

areas Backup 1 and Backup 2 in the local flash memory inside the MicroController XC. The 

backup is restored by selecting File →Restore unit from flash.  This backup function is often 

used to save intermediate versions which can quickly be restored during a programming and 

installation phase. 

 

Important notice: It is good programming policy to take local manual backups when you are working. 

The manual backups can be restored if you do some basic mistake like deleting a program by accident. 

 

Local backups in XC04 and XC04F 
The contents of the PC based units XC04 and XC04F is automatically saved on a local file in the PC 

whenever you  make a change in the programs. 

 

Local backups in XC05 
The contents of the XC05  unit   is automatically saved Flash Area. 

 
 

External backups outside target system 
The external backup is saved internally in the programming tool and can be viewed in the Backup area 

In the information tree. The  external  backup is done by selecting File →Upload application from 

unit. The external backup is restored in the target unit by selecting File →Down application to unit. 

 
General warning!! 
When you restore a local or external backup to the system, the whole application will stop and restart 
after the data load is finished. Therefore, loading backups is normally done with an inactive control 

system or off-line. Taking local or external backups, on the other hand, can be done in the running 

system without disturbing normal system operation. 

 

3.7 Reuse old FirstDoc files. 

You can reuse your old FirstDoc files for compatibility reasons: 

 

1. You can open a old FirstDoc file (.fdo) which will be converted to a FirstGraph file (.mcd) 

2. You can save your project as a FirstDoc file by using File →FirstDoc→Export backup to fdo file 

3. You can reuse you texts and drawing structure by using  File →FirstDoc→Include text and 

pages from firstdocfile. 
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4 Application programs 

4.1 Program structure 

  

Function block nr 4 

Application program 

Properties 
 
Identity 
Clock type 
Priority 
Program protection 

Function block nr 3 

Funktion block nr 2 

Function block nr 1 

Functions 
 

 
 
An application program is divided into function blocks and function modules which are objects which 

you get from the local function library stored inside the MicroController XC unit.  The function blocks 

and function modules will together define the function . Within one program there may be at most 

255 different function blocks, each one containing in turn a maximum of  255 individual function 

modules.  

 

The real-time properties is defined in the  program properties by specifying the clock tick and the 

priority level for the whole program .  

 
The complete  list of properties for an application program is: 

 

Version * The program version is incremented each time the program is changed  

Size* The source code size expressed in Bytes 

Mode* The current program status: 
Unsorted = never sorted  

Unloaded = not loaded 

Stopped =loaded but stopped 

Running=loaded and running 

Clock type  The clock type defineds the basic cycle tick for the application program. The 

function blocks will be run as a specified multiple of the basic tick (see the 

CYCLE and CTRL function block modules) 

The available clock types are:  

time_1 = time clock for fast programs 

time_2 = time clock for normal programs 

soft_1…soft_9 = software clocks generated in the application by the CLOCK 

function module. 
pulse_1…pulse_2 = pulse counter clocks (XC03 version only)  

Priority The normal priority levels are 1….9 , where the lower number represent a 

higher priority. An application program with a higher priority will always 

interrupt all programs with lower priority whenever it is time for execution. 

Program 

protected 

unprotected, protected. If the program is protected, it is not possible to enter or 

display the program in any way unless a correct password is specified ( see 

command PASSWORD on Unit Level). 
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The properties indicated by (*) are filled in by the operative. The remaining properties are specified by 

the user during the design stage using the information tree as is described below. 

 

If you click on “Programs” under the target system in the FirstGraph tool you will have a display of all 

the application programs that exist in the unit. Since the application code are sent automatically from 

the target system ,  the programs displayed in the tool  are always up-to-date and exact copies of the 

running programs. 

 

 
 

 

4.2 Function blocks and modules 

 

Function Blocks 
  TYPE                   IDENTITY 

INPUTS 

PARAMETERS 

Function modules 

 
 

The function block may be regarded as a container for several function module internally. The 

function block is defined by its properties and the function modules contained inside the block. Within 

one function block there may be at most 255 different function modules defining the specific control 

function executed by the block.  
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The function block will  run periodically with respect to the clock tick defined for the program. The 

period is set individually for each block inside the program.  There are two types of function  blocks 

available: 

 

CYCLE

PERIODI1
                                   

CTRL

ONL1
SINGLEL2

PERIODI1
 

 

The CYCLE block executes all the modules inside the block each time the system clock assigned to the 

application program has increased with PERIOD clock ticks. 

 

The CTRL block has a more flexible function allowing the user to change the cycling period, switch the 
block on/off and execute the block once at special events. The inputs to the control module can be 

connected to signal values in other blocks in the same application program. 

 

Function modules 
 
   TYPE     IDENTITY 

INPUTS 

PARAMETERS 

OUTPUTS Function 

 
 

The function modules performs each a specific function as defined by the description in the function 

library in Appendix A. The user connects (“Soft-wiring”) the function modules together to perform the 

control task he wants.  The user will be guided by the FirstGraph tool in the programming work as is 

described later.  

 

Type The module type may be any of the types in the function library. 

Function The module computes new values on all outputs from input values 

and parameter data each block cycle.  

Identity The module identity is an integer 1-255 unique within the specific 

function block. A good rule of thumb is to structure the project so that 

an individual block contains a maximum of 50-80 modules. 

Inputs The inputs may be connected to signal values in the same block or 

other blocks in the same application program. Connections can only 

be done to signals of the same type, see below for available signal 

types.  The input can also be inverted or assigned a fixed value. 

Parameters The parameters are constants specified at the design stage. The 

parameters are module properties that are fixed during running and 
can only be changed manually by the programmer.  

Outputs The result of the module computation will be presented at the 
outputs. The outputs can be connected  to an input in another module 

within the same program. 
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An application project may typically contain 500-8000 different function modules. 

There are about 150 different function modules in the library for all types of functions needed in a 

automation task. Some examples: 
 

 AI 

CARD I1 

Y =R1= 

CH  I2 
MAX R1
MIN R2 
TC R3 

SUM

Z R1ΣX=R1=

 FGEN 

X R1 Y R1 

DX R1 
XS R2 
YN R3= 

AND

S L1&L=L1=

Self
Adaptive
regulator

Pole
Placement

STREGX2

ONL1

NAI1
NBI2
NCI3

LOADL4
DUMPL5

MODELI1

MVR1

AUTOL2
ADAPTL3

U R1

FF2R5
FF1R4
UER3
SPR2

LOR7
HIR6

DUMR9
DUPR8

UMINR2
UMAXR1
SAMPI6
ALFAI5
MDI4

POLER7
BMPLVLR6
KINITR5
RESYR4
RESUR3

MODEI7
WI8

PID

ONL1

IZEROL4

MVR1

AUTOL2
IHOLDL3

HIL L1

LOR5
HIR4
UER3
SPR2

1/TIR7
KPR6

KR9
TDR8

MODEI1

U R1

LOL L2

E R2

 
 

4.3 Automatic sequencing 

The sequencing algorithm 

The order in which the blocks are executed in a program and the order in which the modules are 

executed inside a block is automatically generated by the MicroController operative before the 

program is loaded into the running area.  

 

The algorithm sorts the execution order in two steps: 

 

1. The function blocks within a program is sorted where the execution order is determined by 

the signal connections between function blocks 
 

2. If all functions blocks are correct, the procedure is repeated for all function modules inside all 

function blocks. 

 

The operative will allow the program to be loaded only if all connections are correct. In case of 

programming errors, the load will be stopped and the user must correct the error before loading is 

allowed. 

 

The execution order will then be: 
 

1: The first block 

2: The first module in the first block 

... 

n+1: The last module in the first block 

n+2: The second block 

n+3: The first module in the second block 

... 

m: The last module in the last block 

 
(n is the number of modules in the first block, m is the total number of blocks and modules) 
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The user does not have to and can not specify the execution order. This simplifies programming and 

editing in old programs. You also avoid a lot of hard-found errors in your application program.  

 
A direct sequence 

To understand the sequencing algorithm, it is important to know how the sequencing is done. This will 

be illustrated by an example: 

 

         

1 2 3

4

 
 

The modules/blocks can be executed in the following orders:  1, 4, 2, 3 or 4, 1, 2, 3. Both are correct. 

 

To get a correct execution order, the algorithm looks at one module at a time. It examines the inputs 
and if all inputs come from already sorted modules, the examined module is also sorted. This gives a 

correct execution order. 

 

A loop  sequence  

A somewhat more tricky example is the following: 

 

       

 1 2 3 4 

 
 

In this example there is a loop in the program and it is not possible to define an execution order for 

the modules other than that module/block 1 must be executed first. In this case the user must specify 

where the execution sequence shall start in the loop. This is done with a loop mark  (L). The loop mark 

can be placed in two ways: 

 

        

1 2 3 4

L

1 2 3 4

L

 
 

In the first case, the execution order will be: 1, 2, 3, 4. In the second case the execution order will be 
either 1, 3, 4, 2 or 1, 3, 2, 4 (both are correct). 
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Errors detected  by automatic sequencing 

In the actual case the situation may be much more complicated than in the simple examples above. 

There may be hundreds of module objects  that are connected to each other,  sometimes in loops on 
several levels. The sequencing algorithm simplifies the programming work . It also makes makes the 

program very safe since it prevents any program which is not logically correct to be loaded.  

 

Some typical errors found by the sequencing algorithm are: 

 

• Signal wiring to a nonexisting function module or block 

• Signal wiring to nonexisting signal outputs 

• Signal wiring to wrong signal types 

• Undefined signal  loops between modules or blocks 

4.4 Signal types. 

Data types 
The MicroController XC uses natural data types in all application programs.  Natural data types makes 

it much easier to understand the application programs by the user.   

 

Data type Size Value range 

Logical 1 byte (0,1) 

Integer  2 bytes ( -32767, 32767 ) 

Real 4 bytes ( -1018, ..., -10-18, 0, 10-18, ..., 1018 ) 
Text Max 256 bytes strings of ASCII characters  (parameters only)  

 
The are several types of conversion modules that can be used in the application, see the function 

library.  
 

Remark: If the logical signal is stored in the database, the logical values are convert to bits in order to 

save memory space. 
 

Expandable signals 
Inputs, outputs and parameters in function modules can be either expandable or not expandable. 

Signals that may be expanded are indicated by double lines (=) in the function library. Expandable 

signals make it possible for the user to have a variable number of inputs, outputs and parameters in 

the same type of module. For instance, the AND module contains an expandable input: 
 
 AND 

S L1 L =L1= 

 
 

The following logical operations are done by the same module. In the first case we have a 3-input 

AND-gate and  in the second case we have 6-input AND-gate.  
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 AND 

S L.1 

L.2 

L.3 

AND 

S 
L.1 

L.2 

L.3 

L.4 

L.5 

L.6 
 

 
You can have any number of expansions between 0 and 100. For practical reasons one should 

normally not use more than 20-30 expansions in the same module. 
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5 Programming using FirstGraph 

5.1 Working with program drawings 

Graphical programming online 

The programmer uses various graphical tools described below to do all the programming directly in 

the drawing. With the graphical tools the programmer  can 

 

• Create blocks and modules directly from a local function library 

• Connect signals between objects 

• Invert signal connections 

• Defining signal loops between blocks and modules 

• Set signal names and texts 

• Set descriptions on programs, blocks, pages 

• Make all settings and configurations 

 

There are some very powerful features that are unique for the MicroController XC and the FirstGraph 

tool: 

• All programming is made on line in running systems.  

• The program data in FirstGraph drawings are always up to date, i.e. a copy of the running 
system. 

• The drawings are made automatically.  

• You can interface an unknown program and get it documented 

 

Programming Tools 
The graphical tools you are using when programming are placed at the top of the drawing page: 

 

 
 
The icons are from left to right: 

 
Select Connect Text Block Module Read DB Write DB 

 

The tools means the following 

 

Select Select an object or a signal in the drawing 

Connect  Make a connection between function modules 

Text Input signal text, function text and fixed values on parameters and inputs 

Block Display the Function block library 

Module Display the Function module library 

Read DB Select signals from PAC database. A new RSLIST or RSPAC module will be created. 

Write DB Write signals to PAC database. A new SLIST  or SPAC module will be created. 
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Open the program drawing 

You open the drawing window by clicking on the program under the target system. You will then get a 

complete drawing of the program on the screen: 
 

 
 

The application programs are drawn as control schemes where the function modules are represented 

by graphical symbols and the signal flows are represented by connecting lines. 
 

Normal and Enlarged view  

There are often many objects on each page and it may be difficult to distinguish details. 

The programmer can then switch  beween enlarged view and normal view  by clicking with the right 

mouse button on the drawing. In this way, you can quickly switch between the drawing overview and 

the details in a specific module. When you do enlargement, the enlarged area is centered around the 

point where you click. 
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Scaling 

You can scale the relative size of objects in program . Open any program and select File menu → Scale  

 

The scale factor can be selected 80 to 200, where 140 is the 

normal choice. The scaling is adapted to the standard used in 
the older programmig tool FirstDoc for compatibility reasons. A 

larger factor means that you can have more modules on a 

page. 

 

Examples: 

Scaling factor 120 Scaling factor 180 

 

Move between pages 

To move between pages in the drawing you use the horizontal scroll bar placed in the upper toolbar. 

 

 
 

If you click on the left arrow or the shadow area to the left of the square box you will go to the 

previous page. If you click on the right arrow or the shadow area to the right of the square box you will 

go to the next page. You can also grab the square box with the left mouse pressed and move it 

sideways. The page numbers will be displayed on the right side of the lower status bar. 

 
 

1. The internal page number is used at printout and in some warning messages. The internal 

page number will not be printed (in this example 73). 

2. The drawing page number is sequential for each application program, i.e. 30.12 means page 

page no 12 in program no 30. The drawing page number will be printed and is also displayed 

in the head of the drawing, see section Drawing Head below. 

3. The first module on each page. In the figure, the identity 3:30:9:17 means unit 3:program 

30:block 9.module 17 
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Information on the program page 

The first page in a program looks like: 

 

 
 

The descriptions of the function blocks that are contained inside the program are shown in the lower 

left corner  of the program page: 

 

 
 

Information on the block page 

The first page in the function block displays the block module used (CTRL or CYCLE). For instance if the 

CTRL module is used: 

 

 
 

The descriptions associated with the individual pages inside the block are shown in the left lower 

corner of the block page: 

 

 
 

 

Signal references 

When connections are made between modules on different pages, FirstGraph  generates a list of input 

and output references in the drawings automatically.  

 

The input reference is the page number and the module output the signal is coming from. The 

reference is placed in the left margin of the drawing: 
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In this example, the signal is coming from module nr 3  on page 6.3. Since the signal may come from 

only one source, there is always only one input reference. If the signal comes from another block, the 

block number is added to the reference . 
 

The output references specify all other pages where that specific signal is used The reference is placed 

in the right marging of the drawing: 

 

 
In this example, the signal Limit is used on pages 9.3, 9.4 and 9.5. Since each output signal can be used 

by several modules on different pages, there may also be several output references for each output.  

 

Drawing Head 

The following data is displayed in the drawing head  at the bottom of the drawing: 
 

 
 

Date Date for last change in the FirstGraph file 

Rev. Program version (also shown on the first page of each program) 

Unit MicroController unit number 

Pgm Program number 

Block Block number 

Pg.           Drawing page number 

Cont       Next page number 

 

Text in Drawing 

Text can be entered in the following positions in the drawing. Remember to activate the Text tool in 

the toolbar before you enter text. 

 

Project name: At the top left corner, to the left of “FIRST CONTROL SYSTEMS AB”. The project name 
will be the same on all pages. 

 

 
In this example, the project name is PROCESS 1. 
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Program/Block/page description: At the lower part in the input box “Function”: 

 

 
In this example the description is CYL. POSITION STATUS. The function descriptions will also be 
displayed on the start page of the Application/Program/Block. 

 

Signal names: Click on the output line just to the right of the module and enter the name in the small 

input box. 

 

 
In this example the signal name is Error code. The signal name will also be displayed on all pages 

where the signal is used. 

 

Restructure drawings 
The drawing is updated automatically by FirstGraph but the automatic display may not show the 

function the way the programmer wants. Then there is a simple way of moving modules between 

pages within a function block. 

 

Click on the Select tool  on the Tool bar at the top of the page. Then click on the modules you 
want to move as is shown below. 

 

 
Drawing menu 
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The drawing menu will give two options: 

 

Move to page Move to the page within the block where you want to place the 

selected modules and click on  “Move to page”.  The drawings will 
then be redrawn with the new placement of modules 

Keep on page If you want the selected modules to be drawn on a separate page, you 
move to a page within the block and click on  “Keep on same”.  A new 

page will be inserted immediately before the current page containing 

the modules you have chosen. The drawings will be redrawn with the 

the modules on a new page 

 

 

Display values in the drawing. 
You can display up to 8 values in the drawing. The procedure is 

 

1. Activate the Select tool in the toolbar  

2. Click with the left mouse button on an output near the module 

3. Repeat to display more values. The first one is removed when you select more than eight.  

 
You clear all loggings by selecting Clear all logs in the Logging menu. You can also clear one logging by 

a second click on the value. 

 

 

Example: 

 

 
 

 

Remark. The display function will soon be extended. The current version is similar to the one used in 

FirstDoc.  
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5.2 The programming menu 

You program your application completely in a graphical way using FirstGraph. You create and connect 
the function modules during running by simple tools. FirstGraph will prevent you from making 

erronous signal connections or loading programs that are not logically correct. 

 

Before you start programming you must be connected to a target system that can be either a 

MicroController XC01, XC03 controlling a process or a PC-version XC04 which is running offline. How 

you make your target connection was descibed in section 2. 

 

After you are connected you click on “Programs” for the target system in the information tree to 

display the programs that are present in the unit. They will be updated from the target system at the 

same time you open it or make a change.  Any change will automatically be inserted in the program 
drawings. This means that your documentation is completely up to date at each stage of the 

programming process. 

 

If you click with the right mouse button inside the program display on the right you will open the 

programming  menu: 

 

 
 

The program menu options means as follows: 
 

New Create a new application program 

Edit Edit the contents of the application program you selected. 

Delete Delete the program you selected.  For running safety, you must first 

set the program in “Unloaded” mode before it can be deleted. 

Start program Start the selected program 

Load program Load the selected program  

Stop program Stop the selected program  

Unload program Unload the selected program. 

Copy program Creates a new program as a copy of an existing program. 

 

Some selection may be blocked for safety  reasons since you may be programming a running system.. 

Menu alternatives which are not allowed will be dimmed in the menu and can not be selected. 
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5.3  Create application programs 

Normally the programmer wants to reuse as much as possible from previous projects. Therefore we 

describe some alternative ways of working below. The alternatives described are 
 

• Creating a new program 

• Open an existing program 

• Copy an existing program 

• Reusing programs from other projects 

 
All the options are descibed below. 

 

Create a new program 
If you want to create a new program , you click with the right mouse button in the program area and 

select New from the programming menu.  You will then open the program settings: 

 

  
 

After you have filled in the program properties described below you have started a new empty 

program. 

 

Program number A unique identity for the program 1…255 

Clock type  The clock type defines the basic cycle tick for the application program:  

time_1 = time clock for fast programs 

time_2 = time clock for normal programs 

soft_1…soft_9 = software clocks generated in the application  

pulse_1…pulse_2= pulse counter clocks  

Priority The priority levels are 1….9 , where the lower number represent a higher 

priority. An application program with a higher priority will always interrupt 

all programs with lower priority whenever it is time for execution. 

Description A short description of the program contents 

 

 

The clocks used in the programs and the priority levels are described in more detail later. 
You confirm your settings by “OK”.   

 

The program properties are displayed in the program drawings on the very first page: 
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The properties Version, Size and Mode are automatically filled in by the system and stored locally in 

the unit. The version informs you if someone else has made a change in the program that you are not 

aware of. Since this is a new program the status is “Unloaded” and the version is “0” since no change 

has been made. 

 

Open an existing program 
If you want to edit an existing program  you can either  

 

• Double click on the program with left mouse button 

• Click with the right mouse button on the program and select “Edit” from the programming 

menu 

 

You will then open up the program on its first page which contains the program symbol and its 

properties. If you want to change one of the program properties, click on symbol to open the 

definition window for the program: 

 
 

Remember that you are working with a running program in this case and that the changes you are 
doing will be implemented as soon you end your editing phase. Therefore all changes must be done in 

a careful way.  

 

Copy programs 
You can also copy a program internally and place the copy under a new program number. Open the 

program menu by clicking on the specific program you want to copy and select  Copy program from  

the programming menu. You will then get a definition window where you can specify the new 

program number: 
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In this case we have selected program number 16 and created a copy in program number 155. The 

copied program will be stored as “Unloaded”. 

 

Include programs from other projects  
A very common way to work when programming a MicroController XC is to reuse programs from 

other projects, e.g. special designs that have been made for a special purpose.  You pick the different  

programs and load them into the MicroControllern unit and make the changes you want for the 

specific application. 

 

NOTE: When including programs from other projects they must be stored as  FirstGraph files (.mdr).  If 
you want to reuse programs from FirstDoc files, you must first open the project in FirstGraph to 

convert it and save it as FirstGraph file (.mdr). 

 

The procedure is as follows.  Select  File → Include program from other app. and select the FirstGraph 

file containing the program using the browser. You will then get a list of all the programs in the other 

project: 

 

 
 

Select the program you want to include by double clicking on it and fill in then new program number 

in the definition box: 
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If you fill in a program number that already exists, FirstGraph will give you the options to  either 

overwrite the program or to use another  program number 

 
The program “AGC SELECTION” is now included in the backup area as number 26: 

 

 
 

Repeat this produre until you have included all the different programs you want. When you are 

finished you load the whole upgraded application into the target system  by selecting File 

→ Download application to unit. 

 

Warning:  The target unit will restart when you do the download. 

 

Remark: All the internal drawing structure like comments, page disposition,  signal names etc are also 
copied to the new program you have loaded 
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5.4 Create a new function blocks 

 

If you want to create a Function block  i.e. a container for function modules, 
select the Block          tool from the toolbar. Then  you will get a display of the function block library 

which for the moment consists of two objects  CTRL and CYCLE: 

 

 
 

Detailed descriptions are found in Appendix A. 
 

 Select the block module you want. In this case we select the simpler CYCLE which always runs cyclic 

with a fixed period. Click on the selection and you get a definition window on the screen: 

 

Module number The system will suggest the first free number 

available which you can change. Note that the 

drawings for the function will be placed after 

the first page in ascending order based on the 

block number.   

Description A short description of the contents of the 

function which will displayed at the bottom in 

the block page in  the drawings and also at the 

program page  

 

The function blocks are shown in number order after the program page  i.e. the drawings pages will be 
arranged as 

 

Program properties One page 

Function block 1 One page 

Modules in function block 1  Several pages normally 

Function block 2 One page 

Modules in function block 2  Several pages normally 

etc  
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You find the block start page by locating the block modules: 

 

     
 

The pages after a block module to the next block module is occupied by function modules. 

If you want to change the parameters in the CYCLE modules you do as follows. First select the Text 

tool in the top bar and click on the parameter in the CYCLE module. You will then get an input box 
where you can change the parameter value. 

 

 
The funktion block  number 1 will now run with a period 5 relative to the clock tick for the program. 

 

If you want to change the fix value for period in the CTRL module, you do in a similar way. Select the 

Text tool and click on the value you want to change. You will get an input box where you can specify 

your new value: 

 

 
The function block number 5 will now run with a period of 10 relative to the clock tick for the 

program. In this case you set a fixed value on an input and the number must therefore be preceded by 
“V” . Since it is an input you can also connect it to a signal in another block in the program. How you 

make such connections is demonstrated later. 

 

5.5 Create function modules 

If you want to create a Function module you position yourselves on the page where you want the new 

module to be placed. Then select the Module tool from the toolbar to  get a display of the function 

module library which for the moment contains about 150 objects for all type of automation: 
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Select the module you want by clicking on it,  e.g an AI module reading analog inputs. A general 

definition window will be displayed: 

 

 
 

In the definition window you can specify  

 

Insert on current page You can decide if the module is to be shown on the current page or 

not.  Otherwise it will be placed on a separate page at the end of 

the block. 

Module number The system will select an available number which you can change if 

you want.  

 
And you have created an analog input module on the specific page you decided: 

 

 
Once you have created a module you can 

 

• Expanding inputs/outputs 

• Specify values on parameters 

• Connect it to other modules 

• Invert signal inputs 

• Set loop marks 

• Set signal names  

 

When you program the functions in a MicroController XC, the work essentially consists of configuring 

control objects. The steps are 

 

1. Getting module objects from the function library 

2. Connect the objects to each by drawing lines between them 

3. Specify parameter values 

4. Load the control scheme 
5. Start the control scheme 
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5.6 Define expandable signals and parameters 

Some modules contain signals and parameters which are expandable, i.e.you  can freely select the 

number of signals or parameters between 0-100.    
 

In the FirstGraph drawing you will recognize an expandable signal by the “dot”followed by a number in 

the signal name, e.g.  

 
Summation Function generator Analog input Logical and 

  

 

 

The real input X.n 

is expandable 

The real table value 

YN.n is expandable 

The real output Y.n 

is expandable 

The logical input 

L.n is expandable 

 

The procedure to define the number of expansions are as follows: 

 

1. Activate the Select tool 

2. Click on the module you want to configure 

3. Fill in the number of expansions in the definition window 

4. Confirm the selection with “Save” 
 

           

Example 1:  Summation of 12 inputs Example 2: Function generator with 10 table points 
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5.7 Make connections between modules 

You program by connecting  an input  in one module to an output in another modules. The signals 

must be of the same type (Real, Integer, Logical) and within the same program. It is allowed to 

connect to modules in other blocks in the same program. 

 
To connect modules you must first activate the Connect tool          from the toolbar.  FirstGraph will 

display by colors that you select a correct type: 

 

 “Green” for real signals 

 “Yellow” for integer signals 

 “Blue” for logical signals 

 
 You can connect in two alternative ways 

 

Connect an input to an output. 
The procedure is: 

1. Select an input signal on a module you want to connect by clicking on it. The input is displayed 

in a small square at the mouse pointer. 

2. Move to the page where the connecting module is and point at the outputs. Find one of the 

same type which you see by the color at the mouse pointer. 

3. Click on the selected output and you have made the connection. 

 

Note: An input can only be connected to one output. 
 

Connect an output to an input. 
The procedure is similar: 

1. Select an output signal on a module you want to connect by clicking on it. The output is 

displayed in a small square box at the mouse pointer. 

2. Move to the page where the connecting module is and point at the inputs. Find one of the 

same type which you see by the color at the mouse pointer. 

3. Click on the selected input and you have made the connection. 

 

Note: An output can be connected to several inputs. 

 

You deactivate a connection by clicking somewhere on the drawing surface and the info box at the 
mouse pointer will disappear. 

 

We will show the procedure by a simple example below. 
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Example. A simple PID control loop 
 

We intend to connect  the “x” input on the 

filter module “FILT2” to the first output 

“Y.1” on the analog input module “AI”. The 

procedure is illustrated stepwise below. 

 

 

 

 

 
 

 

 

 

Step 1 

 

Step 2 

 

Step 3 

 
Select the input you want to 

connect by clicking on it with the 

left mosue button. The green color 

means that it is a real signal. 

Move to the module output you 

want to connect to. The origin is 

seen at the mouse pointer. The 

output can be at any page within 

the program 

Point at the output you want to 

connect. The green color shows the 

outputs of the same type. When 

you have found it, make another 

click and the connection is made. 

 

The connection is now made and the 

drawing will be updated automatically. 
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5.8 Set parameter values 

Some modules contains parameters with fixed values. In order to set parameter values you must 

activate the Text tool. The procedure is as follows 

 
1. Select the Text tool 

2. Click on the parameter you want to specifiy 

3. Enter the value in the small input box shown 

4. If you want to specify more parameters within the same module type “RETURN” and you will 

go to the next parameter etc 

 

Examples: 

 

 
 

 
Period in a CYCLE block 

module  

Channel nr in a DI 

module 

Filter time in a 4th order 

low pass filter FILT2 

Table value in a function 

table FGEN. You can 

reach the next table 

entry by typing RETURN. 

 

5.9 Set fixed values on inputs 

You can set fixed values on all inputs. The procedure is as follows: 

 

1. Activate the Text tool. 

2. Click at the input where the fixed value is to be set. 

3. Enter the value as “V” followed by a space and the value 

 

Example: 

 

 
Setting a fixed period in a 

block module 

Setting fixed value in a PID 

regulator 
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5.10 Set an inversion or a loop sign to an input  

Any signal input (Real, Integer, Logical) can be inverted. If you want to invert a signal input you do as 

follows: 
 

1. Activate the Select tool in the toolbar. 

2. Click on the signal input you want to specify 

3. Select the option you want (Loop, Inversion) 

4. Confirm with “OK”. 

 

Example: Signal inversion 

 

 

 
 

Example: Loop sign 

 

 

 

 

 
 

The counter will increase the value up to 1000 and is then reset to 0. 

Note that a loop is drawn in this way, i.e. exits to the right and reenters to the left. 

The loop sign means that the counter “COUNT” is done before the comparision “ICMP” with the limit 

value “1000” for reset of counter. 
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5.11 Read from the internal database 

There are two ways to read data from the internal database, either by manually create a new RSLIST 

or  RSPAC module or use  the“Read DB” tool. 

Click on the “Read DB” button. 

 
 

Browse the database and select the signals you want to use. Multiple signals can be selected by 

holding down the “CTRL” button while clicking on the signals. 
 

 
 

Click on the ”OK” button. 
 

A new RSPAC  or RSLIST module will automatically be created with the selected signals. 
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5.12 Write to the internal database 

There are two ways to write data to the internal database, either by manually create a new SLIST or  

SPAC module or use  the“Write DB” tool. 
Click on the “Write DB” button. 

 
 

Browse the database and select the signals you want to use. Multiple signals can be selected by 

holding down the “CTRL” button while clicking on the signals. 

 

 
 

Click on the ”OK” button. 

A new SPAC or SLIST module will automatically be created with the selected signals. 
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5.13 End a programming session 

You end the programming session either by clicking on the x-square at the upper right corner in the 

drawing or by selecting “Close” in the File menu. When you end a programming session you always get 

the following question from FirstGraph: 
 

 
 

 
 

Yes The changes you have made will be saved locally in the target system. If the 

program status is “Running” or “Stopped” there will also be a hot load of the 

changes in the running area within one program cycle. 

No Then you get a second warning as is shown above. If you leave the program 

without saving, all changes will be lost and no hot load will be done. 

Cancel Do not exit. 

 

This also means that if you are working with a running program you can not exit the program until the 

changes you have done are logically correct.   
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6 Database Structure 

6.1 Signal Pacs and Signal Lists 

A Datapac is a collection of real-time data, which form the basic building block in the database. It is 

used to construct identifiable sets of data which are easy to understand and interface. The internal 

database structure consists of  Signal Pacs or Signal Lists , which are stored in one of memory areas 

inside the MicroController. 

 

Signal Pac 

The simpliest database structure is a Signal Pac which consists of one 

single collection of data consisting of 

• Logical signals 

• Integer signals 

• Real signals 

• Character strings 

There may be at most 255 signals of each type. The signals are identified 

by its number 1,2,3… within respective data type. 

The database name is a 8-character string by which it is identified in 

application programs. 

The Pac version is a 2-byte integer which is changed each time any data 

inside the Pac is changed. The version thus tells any reading module 

whether the Pac has been updated or not since the last reading.  A pac 

which has never been updated since last cold start is given a version 0 .  
 

A signal in a Signal Pac is identified by  

PacName/SignalType/Signal Nr 

 

 

Signal List 

A Signal List is a more complex structure which consists of a number of 

Signal Pacs with a common name. 

 

The signal pacs 1…N have all the same structure, i.e. the same numbers of 
reals, intergers, logics and character strings. Typical use is storage of 

object data of the same type e.g. regulators, valves, motors etc  

 

The signal pac 0 have a different structure. Typical use is storage of data 

which is common to all objects stored in the list. 

 

A signal in a Signal List is identified by: 

ListName/PacNr/SignalType/SignalNr 

 

Signal Pacs and Signal List are used to communicate structured data between application programs 
inside a MicroController XC unit and to exchange data with other system units connected to the same 

network. 

 

Pac Name (8 ch) 

Version 

Logical signal nr 1 

Logical signal nr 2 

Logical signal nr 3 

………………… 

Integer signal nr 1 

Integer signal nr 2 

Integer signal nr 3 

………………… 

Real signal nr 1 

Real signal nr 2 

Real signal nr 3 

……………… 

Character string nr 1 

Character string nr 2 

Character string nr 3 

………………… 

 

List Name (8 ch) 

Signal Pac 0 

Singal Pac 1 

 

 

Signal Pac 2 

 

 

 

……………… 

Signal Pac N 
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6.2 Memory areas 

The Signal Pacs and Signal Lists  can be allocated to different memory  areas or media inside the 

Microcontroller XC unit: 

 
Local database (L) The local database is normally used to communicate signal values 

between application programs. The database is zeroed at cold start 

and the data is not preserved at power off. The local database 

share memory area with the running application programs. The 

memory size is configurable .  

 

Backup database (B) The backup database is normally used to store data that is to be 

preserved at power off. The local backup database is protected by 

battery and the data will be preserved at power off. The memory 

area is fixed and can not be changed by the user. 
 

Global database (G) The global database is normally used to retrieved data from other 

units. The global area is also protected by battery and the data will 

be preserved at power off. The memory area  is fixed and can not 

be changed by the user. 

 

The accessability of the different databases and how they communicate data to internal and external 

units is schematically shown in the figure below 

 

 

 
 

 

 

 

 

 

Global Database 

G 

Local Database 

L 

Backup Database 

B 

Application 

Program 

Modbus  TCP 

Slave 

Modbus TCP 
Master 

RS232 

MicroController XC no 1 

WEB site 

MC XC 

No 2 

MC XC 

No 3 

Ethernet 

Telenet 

Serial  IP 

FirstOpNet 

Modbus RTU 

Master 

Modbus RTU 

Slave 

RS485 

FirstGraph 
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The priciple of communication data on a network is simple and very effective: 

 

• Sending data 
Each unit will send a Pac of data to another unit defined by its IP adress whenever new data is 

present.  The communcation is done with a fast UDP protocol which can run data exchange 

down to about 3-4 msec on the local network if needed. 

• Receiving data 

The receiving unit will receive data from other units in his Global memory(G). He must define a 

Signal Pac or Signal List with a correct name and structure, otherwise the received data is 

dismissed. 

 
There is thus no risk that the local unit will receive data by accident from an outside unit. 

All databases can be read and changed by application programs in the local MicroController unit. The 

contents can also be sent to other MicroController units or Personal Computers (PCs) in the same local 

network using the PUBLIC function module.  

 

Configuring the memory areas 

The memory areas Global (G) and Battery (B)  are fixed in size and can not be changed.  The size of the 

local (L) database area  can however be configured.  Enter Settings →Database settings→Memory 

settings  in the information tree and click on “Local database size” to the right. You will then get a 

definition window where you can specify the memory size: 
 

 
Note that the local area is shared by application programs and the database. Therefore one should not 

exaggerate the memory size. Normal settings are in the range 30-60 kB,  which means that the local 

area can hold a large number of signals sufficient for most applications.  Approximate figures for 30 

kB: 

• Only reals : 5200 values 

• Only integers  : 10500 values 

• Only logicals: 168000 values 

where we have taken the database overhead into account (about 30%). This is more than enough for 

most applications and can be used as a guidance. The system will tell you if a limit violation occurs.  
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6.3 Database display 

Database usage 

From the information tree you can display the different database areas and how they are used for the 
moment.  Click on “Memory usage” in Systems Info to show the usage of data: 

 

 
 

Database display 

You can also display all the contents in the Signal Pacs and Signal Lists that are defined in the 

database.   

 

Enter Database in the information tree and select which memory area you are going to look into 

(Local, Global, Battery). You will then get a complete lists of all Signal Pac and Signal Lists that resides 

in the selected area. 
In order display the values select the Signal Pac or List you want to look at and click on one of  the Pac 

numbers shown. To the right you will then see the current values in all the database signals in the 

selected Pac: 
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6.4 Set database definitions  

It is possible to set description and tag name for each signal in the database. This information will be 

displayed in the drawing if the signal is used. If the user changes the information the drawing will also 

be updated.   
 

It is possible to choose if both tag description should be displayed in the drawing or only tagname or 

description. This is done by selecting “File->Settings” 

 

 
 

Set tag name and description information in Database display 

 

Click on the signal with the right mouse button and select edit: 

 

 
 

Enter the tag name and description and click on the ”OK” button. 
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Import and export signal definitions 
 

Signal descriptions may also be imported from an ordinary text file. It is easy to create a spreadsheet 

in excel   and export it in a tab delimited format. The file should have the following fields: 

 

Media L, B or G. 

Pacname 

 

The name of the LIST or PAC as defined in the XC device. 

Pacnr Pac number: 1--254 

Signr Signal number:  1--255 

Datatype Data type:  L, R or I. 

Tagname Tag name 

Description Description 

 

 
 

 

How to export database definitions 

 

Select ”File->Database definitions->Export”. 

Enter the filename for the exported data. 
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How to import database definitions 

 

Select ”File->Database definitions->Import”. 

Browse for the file you want to import. 

 

d 
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6.5 Setting up the database 

To define the database select Settings →Database settings→Pac database. You will then get a list of 

all the Pacs that are defined in the system.  To create a new Signal Pac or Signal List, click with the 

right mousebutton inside the area to the right and select “New” from the popup window that 

appears. You will then open up the database definition window as is shown below. 
 

 
 

We will demonstrate how a Signal List is constructed. The simpler Signal pac is done in a similar way. 

As was explained above, a signal lists consists of Pac 1…N which all have the same structure and a Pac 

0 which has a different structure.   

 

The settings for a Signal List are described below. 

Media  The media where the Pacs shall reside (Global, Local, Battery) 

Pac type  Select Signal List (SLIST) or  Signal Pac (SPAC) 

PacName The name of the Pac, max 8 characters. Note that the system regards 
capital and small letters as different characters. 

Number of reals Pac0 The number of real signals in Pac 0 (0…255) 

Number of integers Pac0 The number of integer signals in Pac 0 (0…255) 

Number of logicals Pac0 The number of logical signals in Pac 0 (0…255) 

Number of texts  Pac0 The number of text strings  in Pac 0 (0…255) 

Number of reals  The number of real signals in Pac 1…N (0…255) 

Number of integers  The number of integer signals in Pac 1…N (0…255) 

Number of logicals Pac0 The number of logical signals in Pac 1…N (0…255) 

Number of texts  Pac0 The number of text strings  in Pac 1…N (0…255) 

Number of Pacs The total number of Pacs 1…N with the same structure (0…255) 

 

The settings for a Signal Pac is the same as was done for Pac 0 above.  
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6.6 Application program interface 

The user will interface the database  with function modules in the application program. The modules 

are: 
 

L =L3=

RSPAC

ONL1

NLI1

UNITI1

NII2
NRI3

Signal
PAC

MEMT1
NAMET2

DEF L1
UPD L2

R =R3=
I =I3 =

 

L=L3=

SPAC

ONL1

NLI1

UNITI1

FORCEL2

NII2
NRI3

I= I4=
R=R1=

Signal
PAC

MEMT1
NAMET2  

L =L3=

RSLIST

ONL1

NLI1

UNITI1

NII2
NRI3

Signal
List

MEMT1
NAMET2

DEF L1

R =R3=
I =I3 =

PNTI4

 

L=L3=

SLIST

ONL1

NLI1

UNITI1

FORCEL2

NII2
NRI3

I= I4=
R=R1=

Signal
List

MEMT1
NAMET2  

Read data from a Signal 

Pac      

Write data to a Signal 

Pac 

Read data from a Signal 

List     

Write data to a Signal 

List 

 

 
 PUBLIC 

ERR I1 
ON 
FORCE 
S_PNT 
T_PNT 
T_UNIT 
 
BRDCST 
CHS 
S_MEM 
S_NAME 
T_NAME 

RDY  L1 L1 
L2 
I1 
I2 
I3 
 

I1 
I2 
T1 
T2 
T3 

 

 MPAC 

ON L1 

S_PNT I1 
T_PNT I2 

ACT L1 

S_UNIT I1 

S_MEM T1 

T_UNIT I2 

T_MEM T2 
S_NAME T3 
T_NAME T4 

 

RSLISTI

ONL1

UNITI1
MEMT1
NAMET2

NLI1
NII2
NRI3
PNTI4

FRCL2
RSL3 LI =I1 =

I =I2 =
R =R1=

DEF L1

 

SLISTI

ONL1

Signal
List

UNITI1
MEMT1
NAMET2

NLI1
NII2
NRI3
PNTI4

FRCL2
RSL3

IL= I5=
I= I6=
R=R1=

 
Send Signal Pac to 

another unit’s IP adress     

Move data from one  

Signal Pac to another 

Read integer logics 

from a Signal List     

Write integer logics to 

a Signal List 

 

 
TEXTPAC

UNITI1
MEMT1
NAMET2
TEXTT3=  

 

Defines text in a Signal 

Pac      

 

See the module library in chapter A for more details. 
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7 General settings 

7.1 Serial ports settings 

The MicroController XC has four serial ports on the base unit for communication with other systems : 

 

Port Type Usage 

Serial Port no 1  RS232 Loading XC base software 

Programming port using FirstDoc 

SLIP communication via internet 

Serial Port no 2 RS485 Modbus RTU master/slave 

Serial Port no 3 RS485 Modbus RTU master/slave 

Siox port Current Field bus for SIOX IO units 

 

If you click on Serial ports in the information tree the current settings are displayed: 

 

 
 

If no steup is made the system will use a default setting as is shown above.  If you want to change the 

current setup, double click with left mouse button anywhere in the area to the right to open up the 

setup window: 
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The settings are descrbed below: 

 

Serial port nr 1 (Rs232) 

Baudrate  1200, 2400, 4800, 9600, 19200, 38400, 57600, 

115200 (bit/sec) 

Databits  6,7,8 

Stopbits 1,1.5,2 

Parity none, odd, even 

Flow control  None, xonxoff, hardware. 

 

Serial port nr 2-3 (RS485) 

Baudrate  1200, 2400, 4800, 9600, 19200, 38400, 57600, 

115200 (bit/sec) 

Databits  6,7,8 

Stopbits 1,1.5,2 

Parity none, odd, even 

Wiring 485 

Protocol binary.  

Node 0,1,…,255. The MicroController node number for 
external protocols (e.g. Modbus RTU) 

Used as master yes, no 

Checksum CRC 

Master timeout 1,2,3… (sec). The master timeout is the 

maximum time the serial port may be locked by 

a Master communication module (e.g. MREAD, 

MWRITE, COMBIN) before it is released by force. 

 

Serial port nr 4 (siox) 

SIOX used yes, no. Activates the SIOX bus. 

SIOX baudrate 1200, 4800, 9600, 19200 bit/sec 

SIOX terminal used yes, no. Activates Siox terminal. 
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7.2 Clock settings 

If you click on the clocka area in the information tree you will open a setup window for clocks used in 

the unit: 

 

 
 

The settings are described below: 

 

Time_1 

 

1,2,3.... , 60, 100, 150, 200, 250. 
The basic time clock tick for fast application programs 

expressed in msec. 

 Default=50. 

Time_2  0,1,2…. 

The basic time clock tick for normal application programs 

expressed as number of settings for time_1. If value=0 the 

clock is deactivated. Default=0. 

Alive timer Number of base time for alive update  

CPU load measure time 1,2,…. 

The time period for CPU load measurement expressed in sec 
Default=10 sec 

 

The new time set is valid immediately after you have confirmed by “Save”. 
 

Warning: Be sure not to overload the system since all programs will start with the new ticks 

immediately after the change is done 
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7.3 Network settings  

If you click on the Network area in the information tree you will open a setup window for network 

settings in the unit: 

 

 
 
The settings are defined below: 

 

IP adress  For bytes defining the IP adress of the unit  

Net mask  Four bytes defining the net mask of the unit 

Deafault gateway Four bytes defining the internal adress to an XC04 unit 

Enable slip yes, no.  

Enabling the IP serial data transfer on the RS232 serial port. 

Slip timeout (s) The timeout for IP serial transfer.If no data transfer has been 

done within the specified time, the IP serail transfer is 

deactivated and a disconnect string is sent, closing any 

telephone modem that may be connected to the RS232 serial 

port. 
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7.4 Unit config settings 

Unit config is used for defining IP-addresses and port numbers for other XC units and FirstOPNet 

SCADA system. Each number corresponds to a specific unit and is used in the PUBLIC module as node 

number. 
If you click on System settings you will get the following: 

 

 
 

The settings are described below: 
 

Nr 

 

Unit number of another XC unit och FirstOPNET scada system. 

This Is used in the PUBLIC module. 

Enabled  If the current address Is in use. 

IP Address Set the IP Address of the other unit 

Port number Set the port number of the other unit. 
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7.5 System settings 

If you click on System settings you will get the following: 
 

 
 

The settings are described below: 

 

Program protection 

 

If you click on  “Program protection”  to the right you will 

open a window where you can specify a password for entering 

programs.  

Serial IP connect  If you click on “Serial IP connect”  to the right you will open a 

window where you can specify  User/Password for entering 

the serial IP connection via the serial port 

System connect If you click on “System connect”  to the right you will open a 

window where you can specify  User/Password for being able 

to enter the unit for programming. 

System date Set the date/time for the internal calender clock 
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8 Signal Settings 

8.1 Card type selections 

 
 

Separate I/O configurations are made for 
 

I/O controller unit MicroController unit Type selection: XC01, XC03 

I/O expansion card 1..4 Exansion unit Type selection: SCC, KX3 

 

Important notice. If you are connected to one of the target PLC systems XC01 ,XC03 or XC05, the 

programming tool will automatically identify the version and adapt the display to it. If you are 

connected to a XC04, which can be used to design application for all versions, the user must define 

which target he is aiming at, 

 

By clicking on the display to the left, you will open a window where you can select the type you are 
working with. The settings are done in a similar way but we will go through the different variants  

below. The display in the information tree will also be adapted to the type selection: 

 

Type XC01 Type XC03 Type KX3 Type SCC 

 

 
 

 

All the different cards also have digital outputs DO, but there is no specific setup made exccept for 

those used as PWM outputs in XC01. 

 

Remark. The “Peak” and “PWM” inputs in card types XC01 and SCC are optional. Contact First Control 

before use.  
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8.2 Card type XC01 & SCC 

Analog inputs (AI) 
If you click on “AI” in the information tree you open the setup window for analog inputs 

 

 
 

The analog inputs can pairwise be used as differential  or single-ended.  If the single ended is selected, 

there will be two setups for each pair, else only one. Some single-ended inputs can also be supplied 

with NTC resistor for temperature measurements.  
 

This arrangement is made so that you can customize the AI settings so that you get a maximum 

number of channels. Hence if all are single ended you will have a total of 16 analog input channels and 

if all are differential you will have 8 analog input channels in all. 

 

The properties are 

Type  You can select each pair to be either differential or single 

ended.  If single ended is selected, there will be two property 

setups otherwise only one. 

Active  Yes/no. if the channel is used/not use 

Voltage/Current Selection of 0-10V or 0-20mA. 

Max/min  Reserved for future use 

NTC used  Yes/no. Only valid for single ended channels.  NTC inputs are 

only calibrated for channel 5 in XC01 card and for channels 

2,3,5,6 and 9 in the SCC card. Note that “voltage”  must be 

selected. 

Filter time  0,1,2…...,128. The time constant is 2.5 x 2N msec where N is 

the specified integer. E.g.  0,1,2,3,4,5..  means time constants 

2.5,5,10,20,40,80 msec. 
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Function library:  

The following modules are used with analog inputs 

 

 AI 

CARD I1 

Y =R1= 

CH  I2 
MAX R1
MIN R2 
TC R3 

 

 AIC 

Spare  

CARD  
CH  

MAX  
MIN  
TC 

I1  
I2  
I3  

R1  
R2  
R3 

Y =R1= 

 
Read analog inputs                          Read analog inputs 

(older module for 

backward compatility) 
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Thermocoupler inputs (TC) 
If you click on “TC” in the information tree you open the setup window for thermocoupler  inputs 

 

 
 
The properties are 

 

Active  Yes/no. if the channel is used/not use 

Max/min  Reserved for future use 

Filter time  0,1,2…...,128. The time constant is 2.5 x 2N msec where N is 

the specified integer. E.g.  0,1,2,3,4,5..  means time constants 

2.5,5,10,20,40,80 msec. 

 

Function library:  

The following modules are used with thermocoupler inputs 

 

 AIT 

CARD I1 

T =R2= 

CH  I2 
TC R1
TYPE R2 

C – R1-  

 
 

Read thermocoupler inputs   
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Pt100 temperature input (PT100) 
If you click on “PT100” in the information tree you open the setup window for thermocoupler  inputs 

 

 
 

The properties are 
 

Active  Yes/no. if the channel is used/not use 

Max/min  Reserved for future use 

Filter time  0,1,2…...,128. The time constant is 2.5 x 2N msec where N is 

the specified integer. E.g.  0,1,2,3,4,5..  means time constants 

2.5,5,10,20,40,80 msec. 

 

Function library:  

The following modules are used with Pt100 inputs 

 

 AIPT 

CARD I1 

TC R1

PTM – R1-  

 
 

Read Pt100 input   
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Peak measurement input (PEAK)  
The peak measurement is only used in the SCC.  It is used with an accelerometer input and is 

calibrated so that 0-50g corresponds to 0-50VAC RMS at 1000 kHz. 

 
If you click on “PEAK” in the information tree you open the setup window for peak measurement 

inputs 

 

 
The properties are 

 

Active  Yes/no. if the channel is used/not use 

Max/min  Reserved for future use 

Filter time  0,1,2…...,128. The time constant is 2.5 x 2N msec where N is 

the specified integer. E.g.  0,1,2,3,4,5..  means time constants 

2.5,5,10,20,40,80 msec. 

 

Function library:  

The following modules are used with Peak inputs 
 

 AIPK 

CARD I1 

MAX 
MIN 
TC 

R1
R2
R3

PEAK – R1-  

 
 

Read Peak input   
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Digital inputs (DI) 
If you click on “DI” in the information tree you open the setup window for digital  inputs 

 

 
 

The properties are 
 

Debounce The number of consequtive cycles (2.5 msec)  the input reading must be the same 

for the logical value to change. The debounce value will act as a filter on the input 

avoiding false readings caused by external high-frequency disturbances. 

 

Function Library 

The following modules are used with digital inputs 

 

 DI 

CARD  I1  
CH I2 

S =L1= 

 
 

 DIP 

CARD I1 

I =I1= 

 

 DIC 

CARD  
CH  
Spare 

I1  
I2  
I3 

S =L1= 

 
Read digital inputs as 

logicals      

Read digital inputs as 

integer 

Read digital inputs as 

logicals (older version) 
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Analog outputs (AO) 
If you click on “AO” in the information tree you open the setup window for analog outputs 

 

 
The properties are 

 

Active Yes/no. if the channel is used/not used 

Voltage/Current Select 0-10V or 0-20mA. Note that jumpers on the card have to be set as 

well. 

 

Function Library 

The following modules are used with analog outputs 

 

 AO 

CARD I1 

=R1= X 

CH  I2 
MAX R1 
MIN R2 

 
 

 AOC 

CARD  
CH  
Spare  
MAX  
MIN 

I1  
I2  
I3  

R1  
R2 

=R1=  X 

 

Set analog outputs      Set analog outputs     

(older version) 
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Pulsewidth modulated outputs (PWM) 
If you click on “PWM” in the information tree you open the setup window for PWM outputs 

 

 
 

Properties can only be defined for digital output channels 14-16 since they can be used as PWM 
outputs. There are no properties to be defined for channels 1-13. 

 

The properties are 

 

PWM used Yes/no. if the channel is used/not used 

Pulselength start Length of startpulse in µsec 

Pulselength max  Length of period in µsec 

 

Pulse length properties 

start 

max 
 

 

REMARK. Special option that is made for MicroController XC02 and not used with XC01. 
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Function Library 

The following modules are used with PWM outputs 

 

 DOPWM 

CARD  
CH 

I1  
I2  

=R1 = X% 

 
 

Set PWM outputs      
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Pulse counters 200kHz (PC) 
If you click on “PC” in the information tree you open the setup window for pulse counter inputs 

 

 
 

The pulse counter channels  1-2 are the same as digital the input channels  7-8. If the channel is used 

as pulse counter,  the pulse setup will override the digital input setup. 

 

The properties  are 

 

PC used  yes if the channels is to be used as pulse input, else no. 

Clock active This property is only optional for XC01 and means that the 

pulse counter can be used as a clock for application programs. 

(It is standard in XC03) 

 

Function Library 

The following modules are used with pulse counter inputs 

 

 PFQ 

CNR I1 

L1 TF 
R1 NTP 
R2 NP 

 
 

 

I1 

PSET 

CNR 

EN  
NEW  
NP  
T 

_  
_  
_  
_ 

_  
_  
_  
_ 

L1  
L2  
R1  
R2  

 

 

I1 

PLT  

CNR 

TF  
LNT 

_  
_ 

_  
_  
  

L1  
R1  
  

 

Read frequency 
measurement from pulse 

counter      

Set pulse countdown 
period 

Read accumulated pulses 
from pulse counter 
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Digital outputs (none) 
There is no specific setup made for digital outputs except if PWM is used on channel 14-16, see the 

setup for PWM above. 

 
Function Library 

The following modules are used with digital outputs 

 

 DO 

CARD  
CH 

I1  
I2  

=L1 = L 

 
 

 DOP 

CARD  I1  

=I1 = I 

 

 DOC 

CARD  I1  
CH I2  

=L1 = L 

Spare I3   

Digital outputs  Digital outputs in 

parallell (16 bits) 

Digital outputs 

old version 
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8.3 Card type XC03 

Analog inputs 16 bits (AI) 
If you click on “AI” in the information tree you open the setup window for analog inputs 

 

 
 

The analog inputs can pairwise be used as differential  or single-ended.  If the single ended is selected, 

there will be two setups for each pair, else only one. Single-ended inputs can also be supplied with 

NTC resistor for temperature measurements.  

 

This arrangement is made so that you can cutomize the AI settings so that you get a maximum number 

of channels. Hence if all are single ended you will have a total of 16 analog input channels and if all are 

differential you will have 8 analog input channels in all. 

 
The properties are 

 

Type  You can select each pair to be either differential or single 

ended.  If single ended is selected, there will be two property 
setups otherwise only one. 

Active  Yes/no. if the channel is used/not use 

Voltage/Current Selection of +/-10V or 0-20mA. 

Max/min  Reserved for future use 

Filter time  0,1,2…...,128. The time constant is 2.5 x 2N msec where N is 

the specified integer. E.g.  0,1,2,3,4,5..  means time constants 

2.5,5,10,20,40,80 msec. 
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Function library:  

The following modules are used with analog inputs 

 

 AI 

CARD I1 

Y =R1= 

CH  I2 
MAX R1
MIN R2 
TC R3 

 

 AIC 

Spare  

CARD  
CH  

MAX  
MIN  
TC 

I1  
I2  
I3  

R1  
R2  
R3 

Y =R1= 

 
Read analog inputs                          Read analog inputs 

(older module for 

backward compatility) 
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Digital inputs (DI) 
If you click on “DI” in the information tree you open the setup window for  digital  inputs 

 

 
 
The properties are 

 

Debounce The number of consequtive cycles (2.5 msec)  the input reading must be the same 

for the logical value to change. The debounce value will act as a filter on the input 
avoiding false readings caused by external high-frequency disturbances. 

 

 
Function Library 

The following modules are used with digital inputs 

 

 DI 

CARD  I1  
CH I2 

S =L1= 

 
 

 DIP 

CARD I1 

I =I1= 

 

 DIC 

CARD  
CH  
Spare 

I1  
I2  
I3 

S =L1= 

 
Read digital inputs as 

logicals      

Read digital inputs as 

integer 

Read digital inputs as 

logicals (older version) 
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Analog outputs 16 bits (AO) 
If you click on “AO” in the information tree you open the setup window for analog outputs 

 

 
The properties are 

 

Active Yes/no. if the channel is used/not used 

Voltage/Current Select +/-10V or 0-20mA. Note that jumpers on the card have to be set as 

well. 

 

Function Library 

The following modules are used with analog outputs 

 

 AO 

CARD I1 

=R1= X 

CH  I2 
MAX R1 
MIN R2 

 
 

 AOC 

CARD  
CH  
Spare  
MAX  
MIN 

I1  
I2  
I3  

R1  
R2 

=R1=  X 

 

Set analog outputs      Set analog outputs     

(older version) 
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Pulse counters 200kHz (PC) 
If you click on “PC” in the information tree you open the setup window for pulse counter inputs 

 

 
 

The pulse counter channels  1-2 are the same as digital the input channels  7-8. If the channel is used 

as pulse counter,  the pulse setup will override the digital input setup. 

 

The properties  are 

 

PC used  yes if the channels is to be used as pulse input, else no. 

Clock active This property means that the pulse counter can be used as a 

clock for application programs, e,g, to clock the program per 

length unit instead of time unit. 

(It is standard only  in XC03) 

 

Function Library 

The following modules are used with pulse counter inputs 

 

 PFQ 

CNR I1 

L1 TF 
R1 NTP 
R2 NP 

 
 

 

I1 

PSET 

CNR 

EN  
NEW  
NP  
T 

_  
_  
_  
_ 

_  
_  
_  
_ 

L1  
L2  
R1  
R2  

 

 

I1 

PLT  

CNR 

TF  
LNT 

_  
_ 

_  
_  
  

L1  
R1  
  

 

Read frequency 

measurement from pulse 

counter      

Set pulse countdown 

periiod 

Read accumulated pulses 

from pulse counter 
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Pulse counters 4.8Mhz (POS) 
If you click on “POS” in the information tree you open the setup window for pulse counter inputs 

 

 
The pulse counter channels  1-4 are high frequency counters for  pulse counting in high precision 

which are connected by two separate cables on the front of the unit. The pulse counter range is  

 + / - 223 (8388608) pulses starting from the middle of the range. 

 

The properties  are 

Filter time A number 0-255 that is loaded to a hardware filter which 
maximize the frequency input according to the table shown 

below.  The purpose is to remove influence of high frequency 

noise in the signal. Recommended values are in the range 0-20. 

 

Filter 

value 

Max freq 

kHz 

Filter 

value 

Max freq 

kHz 

0 4000 11 333 

1 2000 12 308 

2 1333 13 286 

3 1000 14 267 

4 800 15 250 

5 667 16 235 

6 571 17 222 

7 500 18 211 

8 444 19 200 

9 400 20 190 
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Function Library 

The following modules are used with high frequency pulse counter inputs 

 

 

   POS 
–L1 –  RST 
–R1 –  PSET 
– I1 –   MODE 
 

I1 –  CH 

ERR – L1 –
CY – L2 –
BW – L3 –

LNT – R1 –

 
 

Read and reset the 

pulse counter 
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Digital outputs (none) 
There is no specific setup made for digital outputs. 

 

Function Library 

The following modules are used with digital outputs 

 

 DO 

CARD  
CH 

I1  
I2  

=L1 = L 

 
 

 DOP 

CARD  I1  

=I1 = I 

 

 DOC 

CARD  I1  
CH I2  

=L1 = L 

Spare I3   

Digital outputs  Digital outputs in 

parallell (16 bits) 

Digital outputs 

old version 
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8.4 Card type KX03 

Analog inputs (AI) 
If you click on “AI” in the information tree you open the setup window for analog inputs 

 

 
 

The analog inputs must be set to differential.  In all there are 16 differential analog input channels on 

the unit . 

 

The properties are 

 

Type  Only differential can be selected. 

Active  Yes/no. if the channel is used/not use 

Voltage/Current Selection of 0-10V or 0-20mA. 

Max/min  Reserved for future use 

Filter time  0,1,2…...,128. The time constant is 2.5 x 2N msec where N is 

the specified integer. E.g.  0,1,2,3,4,5..  means time constants 

2.5,5,10,20,40,80 msec. 
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Function library:  

The following modules are used with analog inputs 

 

 AI 

CARD I1 

Y =R1= 

CH  I2 
MAX R1
MIN R2 
TC R3 

 

 AIC 

Spare  

CARD  
CH  

MAX  
MIN  
TC 

I1  
I2  
I3  

R1  
R2  
R3 

Y =R1= 

 
Read analog inputs                          Read analog inputs 

(older module for 

backward compatility) 
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Digital inputs (DI) 
If you click on “DI” in the information tree you open the setup window for  digital  inputs 

 

 
The properties are 

 

Debounce The number of consequtive cycles (2.5 msec)  the input reading must be the same 

for the logical value to change. The debounce value will act as a filter on the input 

avoiding false readings caused by external high-frequency disturbances. 

 

 

Function Library 

The following modules are used with digital inputs 

 

 DI 

CARD  I1  
CH I2 

S =L1= 

 
 

 DIP 

CARD I1 

I =I1= 

 

 DIC 

CARD  
CH  
Spare 

I1  
I2  
I3 

S =L1= 

 
Read digital inputs as 

logicals      

Read digital inputs as 

integer 

Read digital inputs as 

logicals (older version) 
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Analog outputs (AO) 
If you click on “AO” in the information tree you open the setup window for analog outputs 

 

 
The properties are 

 

Active Yes/no. if the channel is used/not used 

Voltage/Current Select 0-10V or 0-20mA. Note that jumpers on the card have to be set as 

well. 

 
Function Library 

The following modules are used with analog outputs 

 

 AO 

CARD I1 

=R1= X 

CH  I2 
MAX R1 
MIN R2 

 
 

 AOC 

CARD  
CH  
Spare  
MAX  
MIN 

I1  
I2  
I3  

R1  
R2 

=R1=  X 

 

Set analog outputs      Set analog outputs     

(older version) 
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Pulse counters 200kHz (PC) 
If you click on “PC” in the information tree you open the setup window for pulse counter inputs 

 

 
 

The pulse counter channels  1-2 are the same as digital the input channels  7-8. If the channel is used 

as pulse counter,  the pulse setup will override the digital input setup. 

 

The properties  are 

 

PC used  yes if the channels is to be used as pulse input, else no. 

Clock active This property means that the pulse counter can be used as a 

clock for application programs, e,g, to clock the program per 

length unit instead of time unit. 

(It is standard only  in XC03) 

 

Function Library 

The following modules are used with pulse counter inputs 

 

 PFQ 

CNR I1 

L1 TF 
R1 NTP 
R2 NP 

 
 

 

I1 

PSET 

CNR 

EN  
NEW  
NP  
T 

_  
_  
_  
_ 

_  
_  
_  
_ 

L1  
L2  
R1  
R2  

 

 

I1 

PLT  

CNR 

TF  
LNT 

_  
_ 

_  
_  
  

L1  
R1  
  

 

Read frequency 

measurement from pulse 

counter      

Set pulse countdown 

periiod 

Read accumulated pulses 

from pulse counter 
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Digital outputs (none) 
There is no specific setup made for digital outputs. 

 

Function Library 

The following modules are used with digital outputs 

 

 DO 

CARD  
CH 

I1  
I2  

=L1 = L 

 
 

 DOP 

CARD  I1  

=I1 = I 

 

 DOC 

CARD  I1  
CH I2  

=L1 = L 

Spare I3   

Digital outputs  Digital outputs in 

parallell (16 bits) 

Digital outputs 

old version 

 

8.5 Card type SCC 

The signal setting is the same as is described for XC01 above. 

 

 

8.6 Setting a whole signal range 

There are fairly many signals to be configured which takes some time for the programmer.  In many 

cases the settings are similar for several channels, e.g. setting voltage/current on analog inputs or 
defining debounce levels for digital inputs. 

 

In order to make the setup work simpler, it is possible to make a common setting for a whole signal 

range as is demonstrated below.  Selected the range and open the definition window. The settings you 

make will be common for the whole range. 

 

In the example below we change the selected analog inputs from “Voltage” to  “Current”. 
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9 Configure Modbus TCP/UDP 

9.1 General settings 

Microcontroller XC supports Modbus TCP/UDP as a standard.  The unit may work both as a master or a 

slave or both at the same time. Select Modbus TCP settings → General settings  and you will have a 

general setup.  

 

REMARK. In master mode the unit can run both with the UDP and TCP protocol. In the slave modethe 

unit can run only with the TCP protocol. 

 
 

 
 

Specification 

 

Enable Modbus TCP Master Yes/no. Select if the unit will act as a master 

Enable Modbus TCP Slave Yes/no. Select if the unit will act as a slave 

Query time(ms) The time period in msec by which new queries are sent to the 

slave nodes  in case the unit acts as a master in case of TCP . 

The nodes will be handled in parallell, i.e. as soon the slave 

node has responded the next query will be sent independent 

of all other nodes.  The time must be at least 50 msec. 

UDP Query time  The UDP queries can run faster. They the time is set as a 

multiple of the base time Time_1. 

UDP Timeout time The timeout waiting for a response from the slave. The time is 

set as a multiple of the base time Time_1. 
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9.2 Modbus TCP/UDP master 

Setup as a Master  
In order to make the Modbus TCP/UDP work you do the following. 

 

1. Define a Signal Pac by name ”$MTCPMS” in the local area (L) which contains 50 integers. It will 
show the status of each query sent by the master. 

2. Define a Signal List by name ”$MTCPM”  in the local area(L) for storage of all the data 

communicated with slave nodes. The list may contain logical and integer signals depending on 

the type of query sent.  The size of the Signal List can be designed freely, but it must be large 

enough to be able to hold all data.  

3. You can specify up to 50 different queries to a maximum of 20 nodes, numbered 1,2,…., 20. 

The queries are defined as is shown below. 

Remark. A good design policy is to structure the signal list ”$MTCPM” so that it is easy to identify data, 

e.g. each pac may contain all data for one query or a one node. 

Specifying Queries 
The queries are defined in a setup table used by the software in the order they are numbered. 

Select Modbus TCP settings → Queries  to open the setup table: 

 

 

Host  The slave nod number (last byte in IP address) 

Function code You select the modbus function code from the list. The list contains the 

supported codes see below 

Address The start adress in decimal notation 

Number of data The number of data to be read or written 

Pac number The pac number in signal list ”$MTCPM” cotaining the data 

Signal number The signal number in the pac where the data storage starts.  

Protocol type You can select TCP or UDP from the list. 
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Function codes currently supported are: 

Code Description Storage in ”$MTCPM” 

01 Read coil status (bitwise reading) Logical values 

02 Read input status (bitwise reading) Logical values 

03 Read holding registers Integer values 

04  Read input registers Integer values 

15 Write multiple coils (bitwise writeing) Logical values 

16 Write multiple registers Integer values 

 

Communication status 

The status for each query in the setup table will be stored in the Signal Pac ”$MTCPMS” according to 

its query number, i.e. the status for Query001 will be stored in integer signal no 1, Query002 in integer 

signal no 2, etc. 

Status 

code 

Description 

0  OK 

1 No connection to node 

2 Pac error 

3 Wrong length in recieved message 

4 Wrong function code recieved 

129 Modbus error ”ILLEGAL FUNCTION” 

130 Modbus error ” ILLEGAL DATA ADDRESS” 

131 Modbus error ” ILLEGAL DATA VALUE” 

132 Modbus error ”SLAVE DEVICE FAILURE” 

133 Modbus error ”ACKNOWLEDGE” 

134 Modbus error ”SLAVE DEVICE BUSY” 

135 Modbus error ”SLAVE DEVICE FAILURE” 

136 Modbus error ”MEMORY PARITY ERROR” 

138 Modbus error ” GATEWAY PATH UNAVAILABLE” 

 

Signal interface 
 

 
 

 
Reading data from a motor 

object 

Writing data to a motor 

object 

Reading error codes for 

Modbus TCP 
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9.3 Modbus TCP Slave 

MicroController unit acting as a slave communicate all data to a master via a Signal List  by name 

”$MTCPS” in the local database (L). The ”$MTCPS”  signal list emulates a register area where PacNr = 

High Byte, SignalNr=Low Byte. 
 

You activate the slave function in the the general setup, see section 9.1. The operative will then  

handle the communication as responses to master querys .  

 

Signal List ”$MTCPS”: 
Pac 

(HB) 

List 

Data 

Signal 

(LB) 

1 Datapac 1 

integers 

1 
2 
.... 
n 

2 Datapac 2 

integers 
1 
2 
.... 
n 

  
.......... 

 
 

 

N Datapac N 

integers 
1 
2 
.... 
n 

 

Addressing convention 
The ”$MTCPS”  interface is configured as a Signal List containing all integers. Each integer corresponds 

to a 2-byte word in the Modbus protocoll. The adressing is as 

 

• Adress High Byte =  Pac nr in the signal list (1….255) 

• Adress Low Byte = Integer signal nr (1....255) in the datapac. 

 

Note. Since the datapacs and signals are numbered without using “0”, the adresses (0,N) and (N,0) can 

not be emulated. 

 

Function codes 
For the moment the following function codes are supported in the Modbus TCP slave case: 

 

Code Description Storage in ”$MTCPS” 

03 Read holding  registers 2-byte integer 

06 Write single register 2-byte integer 

16 Write multiple registers 2-byte integer 
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10 System safety. 

Fatal errors in the system. 

 A fatal error in the system is deteced in three different ways: 

 

Fatal errors 

� Watchdog release in an I/O board. 

� Error trap in the MicroCont. 

� Internal communication failure in the system 

 

 

Fatal errors in the system always means that the whole system or a part of the system is switched off 

since otherwise the system function may be in danger. The system outputs are forced to a safe state:. 

 

Safe state 

� All analog outputs are set to zero voltage or zero current 

� All digital outputs are set zero voltage. 

 

 

which corresponds to what ones gets if the power is switched off.   

 

In order to detect serious software or hardware errors there is a watchdog function in each local I/O 
processor. The watchdog requires a cyclic timer update occuring at least once each 65 msec. Should 

the watchdog timer not be updated or be delayed, the watchdog is released and all or a part of the 

system outputs are forced to the safe state. 

 

If the system software for some reason runs out of order, e.g. tries to execute an illegal instruction or 

tries to access illegal adress areas, there will be an error trap in the main CPU in the XC unit. The error 

trap will enforce a recovery routine to be executed and the system will to go to a safe state since the 
system operation is no longer safe. 

 

Failure in I/O boards 
Each board in the system has its own CPU which generates an Alive Count  which is periodically 

incremented. If the Alive Count update stops, the communicating units will know that there is an 

internal communication failure within the system, which nearly always means that a part of the 

system must go to a safe state. 

 

Consider the internal structure of the MicroController system. A fatal error may occur in four different 

parts of the internal structure, marked by 1,2,3,4 in the figure. 
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XC01 CPU card 

MicroController XC01 unit I/O expansion units 

PMC I/O card PMC I/O card SCC I/O card 

CAN bus 1 2 

3 

4 

 
 

A fatal error may arise in 

 

Case 1. The I/O card in the MicroController unit. 

Case 2. The KX3 or SCC extension I/O cards. 

Case 3. The MicroController XC01 CPU  card holding the system software 

Case 4. CAN bus communication failure 

 
The safety protection in the different cases is described below. 

 

Important notice 

It is the responsibilty of the user to design his control system in such a way that the safe state will 

cause the smallest possible harm in his process in case there is a fatal error in the control system. 

 

Fatal error in I/O card in MicroController unit 
The MicroController I/O card is watchdog protected.  In case the card is subject to a fatal error, 

resulting in a watchdog release, the MicroController will lose communication with all the I/O boards. 

Therefore the whole MicroController system and all its I/O boards must go to a complete stop. 

 

Recovery events 

1. The MicroController XC  I/O board will force all ouputs to 

the safe state, i.e. to zero values. All CAN communication 

will be deactivated. 

2. The MicroController software is forced to a halted state  

by the I/O processor. 

3. The remaining I/O boards will detect that the CAN 

communication has stopped and go to a safe state , i.e. 

zero output values. 

4. The indication leds WD and HLT on the MicroController 

front will be lit RED 

 

The system must be manually resetted, e.g. by switching the power off/on. 
 

Fatal error in I/O expansion card 
In case an  I/O  expansion unit is subject to a fatal error resulting in a watchdog release, only that unit 

is affected. The remaining parts of the system may proceed. Therefore, only the erroneous card will go 

to a safe state. The MicroController will be alerted that one card is not functioning. The specific action 

to be taken in the other part of the system is then defined by the user in his application program. 
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Recovery events 

1. The PMC or SCC extension board where the error occurs 

will force all its ouputs to the safe state, i.e. to zero 

values. All external communication will be deactivated. 

2. The indication leds WD and HLT on the expansion unit 

will be lit RED 

3. The MicroController software is alerted by the IOSTS 

function module that the communication with the card is 

lost. Appropriate action is defined by the application 

software done by the user. 

 

The expansion card must be manually resetted, e.g. by switching the power off/on for the card. 

 

Software failure 
The system is protected against two types of fatal events in the running software: 

 

� Time overdue  

� Software failure. 

 

The recovery events are described below. 

 

Time overdue.  

The main software is continously updating an Alive count, which is incremented once each basic time 

cycle and is read by the I/O processor. If the Alive count update stops for some reason, the I/O 

processor go to a safe state and release the watchdog,  The time overdue function will protect high-

priority system programs not being executed as they should. 

 

Recovery events at time overdue. 

1. The PMC I/O board will force all ouputs to the safe 

state, i.e. to zero values. All communication will be 

deactivated. 

2. The MicroController software is forced to a halted 

state since the software can no longer be trusted. 

3. The remaining I/O boards will automatically go to a 

safe state, i.e. to zero output values, since the CAN 

communication has stopped. 

4. The indication leds WD and HLT on the 

MicroController front will be lit RED 

 

The system must be manually resetted, e.g. by switching the power off/on. 

 

Software failure.  
The system is also protected against software failures during execution which may occur e.g. due to a 

hardware failure on the XC01 card. If such an error is detected via an error trap, a call is made to an 
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error routine with a HALT order. The error routine will check which type of program is executing at the 

time for the HALT. 

 

 If the executing program is a high-priority system program or an application programs the error will 
result in a total system stop. The recovery events are as follows.  
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Recovery events at software failure (High priority programs) 

1. All the MicroController software is forced to a halted 

state since the software can no longer be trusted.  

2. The PMC I/O board will force all ouputs to the safe 

state, i.e. to zero values. All CAN communication will 

be deactivated. 

3. The reamaining I/O boards will automatically go to a 

safe state, i.e. to zero output values, since the CAN 

communication has stopped. 

4. The indication leds WD and HLT on the 

MicroController front will be lit RED 

 

In this case, the result is the same as in a watchdog release, i.e. a total system stop. The system must 

be manually resetted, e.g. by switching the power off/on. 

 

If the executing program is a low priority system program (e.g. memory test, signal monitoring, 

background programs), only the specific program causing the error will be stopped. The recovery 

events are in this case as follows. 

  

Recovery events at software failure (Low priority programs) 

1. Only the program in the MicroController causing the 

error will be stopped and can not be used. The 

application programs will continue to run.  

2. The indication leds HLT and ERR on the 

MicroController front will be lit RED. The HLT Led will 

be flashing. 

 

The application programs will thus go on working, but the error should be handled as soon as possible. 

No immediate manual reset is needed, but the system should be reseted at the first suitable time. 

 

Remark 1. If resetting the system does not work, there is some permanent error in the system which 

must be corrected. 
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CAN bus communication failure 
If the CAN bus communication between the MicroController and an I/O expansion unit is not working, 

the expansion card is no longer safe and must go to a safe state. The recovery events are as follows. 

 

Recovery events 

1. The KX03 or SCC extension board which gets no update 

from the MicroController unit will force all its outputs to 

the safe state, i.e. to zero values. 

2. The expansion card will be operational as soon as the 

communcation with the MicroController is restored. 

3. The MicroController software is alerted by the IOSTS 

function module that the expansion board is no longer 

operational. Appropriate action is defined by the 

application software done by the user. 

 

Memory error check during running 
As long as the MicroController is working, the memory will continously be checked for  

inconsistency. The check is made in the background, i.e. all time the XC01 is not occupied by other 

tasks. The memory check includes the following: 

 

Memory check 

� All RAM areas that may contain real-time data are 

continously check by read/write instructions during 

running. 

� All FLASH areas containing system software are protected 

by check sums for each individual part. The check sums are 

continously checked during running.  

� All DATABASE areas are checked for structural errors during 

running. 

� All FILE SYSTEM areas are checked for structural errors 

during running. 

 

A memory error will be displayed by  the ERR led indicator on the MicroController front being lit RED. 

Non-fatal memory errors will also be sent to the system message queue, see the QUEUE command 

and the listing in Appendix C. 
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System error alert to external systems 

External system may be alerted by an 24 VDC signal if the MicroController system goes to a complete 

stop, e.g. due to a watchdog release or a software failure. One digital output signal can permanently 
be set to “1”, as 

 
 DO 

CARD    1 
CH          1 

I1  
I2  

   v 1  L.1 

 
 

In this case digital output channel nr 1 on the card nr 1 is set to “1”.  For the external system this signal 

means “MicroController is OK”. 

 

As long as the MicroController is running, the digital output will be 24VDC. If the MicroController is 

stopped for some reason, all outputs will be set to the safe state, i.e. the digital output goes to 0V. 

 

I/O status alert in application programs 
As long as the MicroController is working, the errors in the communication and process interface may 
be detected in the application program using the IOSTS function module: 

 
 IOSTS 

IO
SIOX

AI
TC

PTM
PEAK

AO
DI

PC
DO

PWM

I1 –  CARD 

– I1 –  
– I2 – 
= I3 = 
= I4 = 
= I5 = 
= I6 = 
= I7 = 
= I8 = 
= I9 = 
= I10 = 
= I11 = 
 

 
 

The module displays the error codes (0=no error detected) for all types of process I/O. See Appendix A 

for more details. 

 

Errors appearing in the communication with external sources can be read directly from the ERR output 
on the interface modules, see Appendix A for more details.  

 

  



 Manual MicroController XC Doc.Id: 1707-01/JÖ Dat: 2017-10-11 

  

 

 

MicroController XC manual 
version 7.docx 

www.firstcontrol.se Page: 100 (121) 

User authorization. 
The MicroController system protects the system from unathorized use. In the present software 

version, the system is protected against 

 

� Unauthorized use of IP communication on the RS232. 

� Unauthorized use of the application project stored in the MicroController 

� Unauthorized use of an individual program that is protected   

 

The authorization means that the user must specifiy different User name and Password before he is 

allowed to enter the specific parts of the system. 

 

Important notice. 

Be sure to remember your passwords. Especially the User name/password that is used to enter the 

application project from public level must be remembered since it may not be possible to restore 

contact with the system if you have forgotten the password. In that case you must contact First 
Control. 
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11 XC05 system commands 
 
 

The XC05 has a number of security features used to clear and restart the unit. These can be found in 

the menu “File->Special->XC05 system commands” in the main window. 

  

11.1 Force restart 
 

This command is used for restart the unit. It overrides normal shutdown of the XC05 device and forces 

a hard shutdown of the system.. 

 

11.2 Force restart and clear filesystem 

This command will clear all programs and settings in the unit and restarts the device. Warning ! All 

programs and settings will be lost. Used when, for example, the device Is overloaded. 

 

11.3 Update firmware* 

 

This command is used to update the firmware of the unit. The file extensions should be “.xc5” or 

“.ca5”. Warning ! This will overwrite the current version of XC05 firmware. A local backup of old 

firmware will be created an can be retrieved by contacting First Control. 

11.4 Show CAN statistics 

This command is used for displaying different parameters for the CAN communication when an 

external  IO card is connected to the unit. 
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12 Modelica simulation (Only XC05) BETA 

 

 

The XC05 unit has the possibility to simulate models written in the MODELICA language. The 

simulations are run in real-time. Up to 50 unique models can be downloaded to the XC05 unit and use 

in a arbitrarily number of instances. Below is a example of the MODELICA tree of models in the XC05 
unit. These are already compiled models residing in then XC05-unit. 

 

 

The columns has the following meaning: 
 

• Internal name -  Internal tagname of the model. Set by the user at compile time.  

• Original name  - Original modelname for the Modelica-file. 

• GUID                 - A unique identifier set at compile time. 

• Description       - The description of the model from the Modelica-file. 

12.1 Add/edit and compile a new model 

The following step should be taken when adding a new MODELICA model. If the internal tagname 

corresponds to an old one already in the list the old model will be replaced by the new one. 

 

1. Select the “Modelica models” node in the left tree. 

2. Right click in the right part of the window. The following menu will be displayed. 

 

 
 

3. Click on “Add/update model” 

4. The following window will be displayed. 
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5. Click on then “…” button on the right of “Model file” to select a Modelica model file. In this 

example we use the classic “Bouncing ball” model. 

 

 
 

6. Click on the “Open” button to select the file. 

 

 
 

7. A MODELICA file may contain several models. To select a model from the model file, click on 

the “…” button on the right of “Model to compile. The following window will be displayed: 
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8. In this example the MODELICA file only contains one model: “BouncingBall”. Select the model 

in the list and click on then “OK” button. 

9. The last thing we has to do is to choose an internal name for the model.  In this case we 

choose the  name “Bounc1” 

 

 
 

10. Now we are ready to compile the model. Click on the “OK” button. The following message will 

be displayed.  
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11. Click on the “OK” button.  The compilation will now start and the following window will be 

displayed. 

 

 

12. The compilation time of the model depends on the size and how complex the model is. For a 

small model  as “Bouncing ball” the compilation time is about 1-2 minutes.  Warning ! It is 

advisable not to abort the compilation in the current version. Doing so, may result in 

unpredictable behavior. 

13. When the compilation is finished., status information will be shown. 
 

 

 

14. If the compilation succeeded the last line will be: “Create library finished”. 

15. Click the “Close window” button to return to the main window. 
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16. The newly added model now appears in the modellist. 
 

 

12.2 Edit or show the model source code 

The model source code can be displayed and changed by doing the following steps: 

 

1. Right click on the model you want to change and click on “Edit model”. In the current example 

we are using Bounc1. 

 

 

2. The following window is displayed. 
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3. This is the models source code. The user can make changes. If so, click the button “Save and 

recompile” after the changes are made. Otherwise click the “Cancel” button” to return to the 
main window. 

 

12.3 Delete a model in the model list 

If a model  is deleted from the modellist all running instances of the model will be stopped and the 

corresponding files on the XC05 unit will be deleted. To delete a model in the model list do the 

following steps: 

 

1. Right click on the model which are going to be deleted. 

 

 
 

2. Click on “Delete model”. The following message will be shown: 
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3. Click on the “OK” button to confirm deletion or “Cancel” to cancel the action. 
 

12.4 Select variables from the model to be used in application 

 

When the model is compiled, variables of type inputs and outputs are automatically selected. 

In the example “Bouncing ball” above, no variables are  defined as inputs or outputs. 

The user may choose any variables in the model as outputs in order to use them in the application. 

To choose variables from the model  do the following way ( in this case we use the Bouncing ball 

mode): 

 

1. Double click on the model in the right window 

 

 

2. The following is shown. As one can see no variables I shown. This is because no variables are 
defined as “Inputs” or “Outputs”  in the original model. 
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3. In order to show the internal variables of the model right click in the right window and select 

“Add/Delete variables” 

 

 

4. The following window is displayed. As one can see now variables are selected. 
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5. In this example we want to show the height and the speed of the bouncing ball, e.g. “h” and 

“v”. To include them for use in the  application click on the box next to the variable: 

 

 
 

6. Click “Save” to save the changes and return to the main window. 
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7. As we now can see, the variables we selected are displayed in the main window. 

 

12.5 Modelica application module 

 

 
 

The Modelica application module is used to run simulation inside an application program. In consists 

of inputs, outputs and module parameters. The number of inputs and outputs of the module may vary 

depending of the structure of the underlying model definition.   
 

• “ON” . This input specifies  if the simulation should be active or not. If the input changes state 

from “False” -> “True”, the simulation will start from time 0. If the input changes state from 

“True” -> “False”, the simulation will be terminated and  reseted. 

• “HOLD”.  This input is used for temporarily stop the simulation. If “True” the simulation will 

hold  at the last simulation step until the input is “False”. If “ON” is false this input has no 

meaning. 

• inp.1 .. inp.N”. These inputs corresponds to the variables in the underlying model that are 

defined as inputs 

• “STEP”. This parameter specifies the time resolution of the simulation in seconds. E.g. 0.02 as 

in module above is 20 ms. 

• “MODELNAME”. Specifies the internal tag name of the model to be used from the library of 

compiled models in then XC05 unit. 

• “ERR”. This output tells if something is wrong with the model  simulation. A non zero value 
indicates that something is wrong in the simulation. For a full list of error code see section 

“Modelica error codes” below. 
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• “TIME”. This output displays the current  time of the simulation.  

• “outp.1 …outp.N”.  These outputs corresponds to the variables in the underlying model that 
are defined as outputs. Internal variables selected by the user in “ADD/DELETE variables” will 

also be included here. 
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12.6 Example 1: A simple dynamic model in an application. 

A model can be used in the application several times.  A separate instance will be created for each 

application module.  The following example will demonstrate how to create a new program and how 
to add the MODELICA application module. We will use the previously defined and compiled “Bouncing 

ball” model. 

 

1. Click on the program node in the left part of the window. 

 

 
 

2. Click on the “Edit->New” menu to create a new program. 

 

 
3. The new program window will be displayed. 
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4. Enter a free program number, in this example we choose number 3.  
5. Enter the description of the program, in this example we choose “Test of bouncingball” 

6. Click on the “OK” button to create the new application program. 

 

 
7. Double click on the newly created program to open the program editor. 

 

 
 

8. Click on  the”BL” icon to create a new cycle block.  
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9. Click on “New module” icon to select a new module. 

 

 
 

10. The following window is displayed. 

 

7 

 
11. Double click on the ”MODELICA” icon. The following window will be displayed. 
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12. This window will display all models that are compiled and ready to be used in the XC05 unit. 

The application model will automatically show the inputs and output of the corresponding 

model. In this example we choose the “Bounc1” model which is the internal tag name of the 

previously compiled “Bouncing ball” example. Click on then “OK” button for adding the 

Modelica module to the program. 

 

 
13. Now we have created a Modelica module which are based on the model ”Bounc1. The step 

time is automatically set to 0.02 seconds, which will be enough for most simulations. Also the 

input“ON” is set to “0 (False)” in order to prevent execution before the user has finished 

editing the program. 

14. Click on the menu  “File->Close” to exit the program editor. 
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15. The following message will be displayed. Click on the “Yes” button to save program changes 

and return to main window. 

 

 
 

16. Now we have to load and run the program.  In order to do so , click on the newly created 

program in right window to select it. 

17. Click on menu “Edit->Load program” to load the program. 
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18. Start the program by clicking on the menu “Edit->Start program”. 

 

 

19.   Now the program is running. Double click on the program in the right window to open the 

program edit and locate the modelica module. 

20. Start logging of the outputs  (ERR,TIME, h and v) by clicking on each of the outputs. 

21. Press the “SHIFT” button and click on the h and v outputs in order to enable graphical logging. 
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22. All values are zero because the “ON” input still I zero (false). 

23. Turn on the simulation by change the value on the “ON” input to 1 (True) and click on the 

menu “File->Save program changes” to save changes in the XC05 unit. 

24. Now the simulation starts. 
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